Return to the Tomato Pests & Diseases Forum | Post a Follow-Up

 o
Blight Again?

Posted by daryll50 PA (My Page) on
Tue, Jun 8, 10 at 11:26

I had blight last year (not sure if early or late) and it appears something same/similar now. I have been clipping the bad foliage and spraying with Daconil Fungicide. I also purchased "Garden Safe" Fungicide by Schultz but have not opened it yet (still using up the Daconil). Clipping and spraying seems to SLOW the spread, but perhaps not enough. Any help with exactly what my plants have and what exactly to do will be appreciated.

Image link: Blight Again? (45 k)


Follow-Up Postings:

 o
RE: Blight Again?

Looks like early blight to me. I am in northern VA and I have some early blight as well.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Tomato Pests & Diseases Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here