Return to the Texas Gardening Forum | Post a Follow-Up

 o
Jim's Mexican Flame Vine is Blooming!

Posted by rock_oak_deer 8a TX (My Page) on
Fri, Mar 2, 12 at 16:42

I posted on my blog about the Mexican Flame Vine
I got from Jim a couple years ago.

Please click on the link, the photos are too large to upload here.

Here is a link that might be useful: Mexican Flame Vine Post


Follow-Up Postings:

 o
RE: Jim's Mexican Flame Vine is Blooming!

Such a pretty color.

You guys always give me zone envy with what you have going this time of year. ha.


 o
RE: Jim's Mexican Flame Vine is Blooming!

Lookin' good, Shirley! Mine isn't even setting buds yet.
Jim


 o
RE: Jim's Mexican Flame Vine is Blooming!

I miss mine:( lost it last winter when it got so cold; and it was just getting so big and beautiful, covered with blooms that year.
Hey, Jim, got any to swap?


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Texas Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here