Return to the Texas Gardening Forum | Post a Follow-Up

 o
No buds on agapanthus

Posted by ann_in_houston z9 Houston (My Page) on
Fri, Mar 28, 14 at 19:34

I usually have buds by now, but I'm not seeing them this year. Is it too cold, yet? Am I wrong about when they bud out?


Follow-Up Postings:

 o
RE: No buds on agapanthus

needs to be warmer.


 o
RE: No buds on agapanthus

Thanks. I thought as much. Maybe this means they'll last longer into the summer.


 o
RE: No buds on agapanthus

most stuff is delayed this year because of all the cold we had. My amaryllis are just starting to bloom and usually they are done by now.
Tally Ho!


 o
RE: No buds on agapanthus

Hi, Tally


 o
RE: No buds on agapanthus

Hi Ann!

walking around campus this week I noticed none of them have blooms yet.
Tally Ho!


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Texas Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here