Return to the Texas Gardening Forum | Post a Follow-Up

 o
Impatiens and other perenials plus azaleas

Posted by char35 9 (My Page) on
Tue, Sep 27, 11 at 15:47

I fertilized my perenials in June with time release fert.for flowering plants. The blooms are now gone. Can I fert. again with time release food? Usually I have blooms through December. But, this has not been a usual summer.
I lost several azaleas. The others look stressed. What can I do to keep from loosing them also? They are well mulched and were fed in June.


Follow-Up Postings:

 o
RE: Impatiens and other perenials plus azaleas

I feed my azaleas after they quit blooming until September...........NO MORE then until after they bloom again. I am in North Texas and have no experience in your zone.


 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Texas Gardening Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Please review our Rules of Play before posting.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here