Return to the Vines Forum | Post a Follow-Up

 o
Frost Damaged Wisteria

Posted by maxville TN (My Page) on
Wed, May 23, 07 at 15:21

We had a really bad frost here in Nashville, TN in April. I had beautiful purple flowers on my 4 year old wisteria vines. They were badly affected by the frost. Now, at the end of May, there are NO leaves on the vines NOTHING. What should I do? I hope that I don't have to prune the vines back to its original size (3 feet). The length of the vine now is about 20 feet. PLEASE let me know what I need to do. I would greatly appreciate it.
Thank you!


Follow-Up Postings:

 o Post a Follow-Up

Please Note: Only registered members are able to post messages to this forum.

    If you are a member, please log in.

    If you aren't yet a member, join now!


Return to the Vines Forum

Information about Posting

  • You must be logged in to post a message. Once you are logged in, a posting window will appear at the bottom of the messages. If you are not a member, please register for an account.
  • Posting is a two-step process. Once you have composed your message, you will be taken to the preview page. You will then have a chance to review your post, make changes and upload photos.
  • After posting your message, you may need to refresh the forum page in order to see it.
  • Before posting copyrighted material, please read about Copyright and Fair Use.
  • We have a strict no-advertising policy!
  • If you would like to practice posting or uploading photos, please visit our Test forum.
  • If you need assistance, please Contact Us and we will be happy to help.


Learn more about in-text links on this page here